Reset Search
 

 

Article

ScreenFlow: Mac OS X 10.13 High Sierra Support

« Go Back

Information

 
Details

ScreenFlow on Mac OS X 10.13 High Sierra 

Screenlow 7:

ScreenFlow 7.1 have been tested and confirmed to work with High Sierra. If you are on a previous version of ScreenFlow, we highly recommend that you do not update to the latest OS as there is compatibility issues..
Download ScreenFlow 7.1 here: http://dynamic.telestream.net/downloads/download-screenflow.asp?prodid=screenflow 
 
 

ScreenFlow 6:

You have the following options:
  1. Upgrade to ScreenFlow 7 for only $39 dollars
  2.  Download 6.2.3 which has been tested and confirmed to work with High Sierra.  
Mac App Store customers, contact our Sales team with a screen shot of your purchase
  1. Indicate if you are interested in upgrading to v7 for $39.
  2. Request a ScreenFlow 6 serial number and download at no cost.
 

ScreenFlow v5 and earlier

ScreenFlow version 5 and earlier will NOT be compatible with High Sierra. If you are on a legacy version of ScreenFlow, we highly recommend that you do not update to the latest OS as there is compatibility issues. 

You have the following options:
 
  1. If you are running an earlier MAC OS X, consider updating your OS version for FREE.
  2. Consider upgrading to qualify for support and take advantage of the many new features. Please contact our sale team to assist you with our upgrade.
Attachment 

Feedback

 

Was this article helpful?


   

Feedback

Please tell us how we can make this article more useful.

Characters Remaining: 255